1

Possible Duplicate:
Please disable Enter to submit comments

This problem may be specific to Mac, or may be specific to Firefox. When I enter a comment on an answer, if I type in Japanese, when I press Return to do a kanji conversion the comment gets added immediately and I have to press "Edit" to put in more text. The Return key seems to be captured by the form and interpreted in the same way as a 1-line text field (i.e. "Go"). It's like this because newline characters aren't allowed in comments, so the only function of the Return key is to finish your comment, but when using an IME it isn't working like it should.

Edit: Here's the way this happens:

I type in にほんご, then press the space bar to highlight the choice for 日本語, then press Return to select that choice. The comment is immediately saved, even though I want to type more.

Is it possible to turn off the submit on return feature?

marked as duplicate by rcjsuen, poke, Amanda S, bdonlan, Tsuyoshi Ito Jun 3 '11 at 21:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged .