4

Why is this question wrapping strangely?

  1. The word unfavourable is split across two lines:

    If you edit the post, there doesn't seem to be a space between unf and avourable. In fact, if I change my browser font size, it wraps into unfav and ourable, or into u and nfavourable, and so on. It seems to wrap anywhere.

    We expect Japanese text to wrap mid-word like this, but it's weird for English text.


  2. This text is wrapping way to the left of the margin:

    wrap2

    Why is it wrapping over there?


  3. When I edit the post, it wraps funny in there, too:

    wrap3

    It doesn't seem like there are newlines or special characters making it wrap there.


What's going on here? I'm confused!

7

It turns out every space in the post was a non-breaking space! It looked like this when I saved it to disk:

A and B were involved in negotiations. A was in a superior position, but there was one and new unfavourable condition that if B knew about, would put A in a huge disadvantage.

Copying and pasting the text fixed it, because my browser copied the non-breaking spaces into the clipboard as regular spaces. (That's why I had such a hard time figuring out what was wrong!)

Apparently this happens when the OP composes a post in Evernote and copies it to the official Android SE app. So the OP can avoid doing that, and if it happens again anyone can fix the posts by copying and pasting all the text in the browser field (which accepts only plain text as opposed to the app)!

Problem solved!

You must log in to answer this question.