2

I followed the instructions. Went to System Preferences, added everything and I have a Flag at the top of my screen which I can click to give me US, Romaji, Hiragan and Katakana.

I would like to enter for example Biru where the "I" is long.

I select the Romaji keyboard but I do not know how to enter the long "I" vowel. Is this possible? Right now it seems like the US keyboard and the Romaji keyboard selections act just the same.

2
  • Do you mean the long vowel sign "ー"? If so, press hyphen. – broken laptop Aug 4 '16 at 11:38
  • Maybe he means 'i' but instead of having a dot above, it's a dash. – Flaw Aug 4 '16 at 12:35
2

If you want a long 'i', hold the key down for longer.

No, really. I'm serious. Holding down the key for longer triggers the accented character input menu, allowing you to enter the macron. (Note that for this to work, key repeat cannot be set to 'Off' under System Preferences > Keyboard.)

It's also worth noting that the romaji layout is essentially a straight copy of the underlying layout, and personally I find it to be of limited usefulness. What I personally do is to just enable the hiragana input mode, and switch languages entirely to enter the Japanese IME, but your mileage may vary (I have Command-Space configured in system preferences to switch input languages, relegating Spotlight to Ctrl-Space, but again, YMMV.)

2
  • IIRC you also need a special setting turned on to do this, otherwise it'll just keep typing a bunch of i. – Blavius Aug 5 '16 at 15:14
  • @Blavius: Indeed. It's covered in the linked help article, but I'll edit it in. – Williham Totland Aug 5 '16 at 15:15

You must log in to answer this question.