6

Tried many ways and searched on Google but I am unable to input the dash for long vowels in Japanese under OSX.

I am using katakana input mode.

Anyone knows how to do?

4
  • 6
    Have you tried a hyphen/dash - (which must be somewhere on your keyboard).
    – Earthliŋ Mod
    Commented Feb 26, 2017 at 11:32
  • 2
    Just found how to solve it. "Hyphen/Dash" is a different character. However, if I press the key right to the "0" number, I get this special character. Commented Feb 26, 2017 at 14:47
  • 1
    Is this not the same key as the one you press to get the hyphen/dash when you're not in katakana input mode?
    – Earthliŋ Mod
    Commented Feb 26, 2017 at 16:39
  • It depends on the keyboard. In hiragana, yes, it is the same key. Commented Feb 27, 2017 at 14:21

1 Answer 1

1

If you don't have a standard QWERTY layout, the keys might be off.

E.g. I have a german keyboard, in it the ー would be at the "ß" next to the zero, even if it doesn't seem so. But you'll also have "z" and "y" changed...

The best is to change the keyboard for Romaji (no idea why this doesn't happen automatically...

tl;dr;

Go to the Keyboard Settings and select The japanese-Romaji input source. You'll see the current layout (This is the default): enter image description here

To sort it out, scroll down to "Romaji Layout" and select "ABC - QWERTZ" enter image description here

After changing it you'll see the new layout, in this case, the german one: enter image description here

If you have any other non-standard layout this might help as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .