2

A few days ago, I’ve decided to switch from Romaji input to Direct Kana input on my computer (using windows IME). Didn’t take me long to get accustomed to it, and I’m liking it a lot. However, I cannot figure out how to input a tilde. My physical keyboard is a standard Swiss layout, like in the following image (plus numpad and function keys).:

Swiss Keyboard Layout

With Romaji input, I could type tilde by hitting the key below ESC (labeled § on my physical keyboard), but doing so with Direct Kana input produces ろ. As far as I can tell, no combination of shift, alt-gr and other keys produces a tilde.

Is there another way to input tilde on the Japanese Kana layout without having to resort to Alt-Codes (perhaps by editing the layout directly, which I’m open to doing if it’s plausible to do).

migrated from japanese.stackexchange.com May 1 '18 at 7:08

This question came from our site for students, teachers, and linguists wanting to discuss the finer points of the Japanese language.

1

This page explains how to input while in kana/kanji mode:

カナ漢字入力の場合

Shiftー 々 ^ へキー押して「ゑ」を入力し、F11キー押して「~」に変換してから、F10キーを押す


When in kana/kanji input

Press Shift + ー 々 ^ へ to input 「ゑ」, press F11 to convert to 「~」 and press F10.

It's not always clear how your operating system assigns a keyboard layout to a physical keyboard with a different (physical) layout. Your physical layout has two Win Keys, which likely are mapped to Windows but no 変換 or かな・ローマ字 which might simply be unassigned. You might have to remap physical keys to keys which perform a certain function in the Japanese layout.

  • I’m not entirely sure what button I’m supposed to press together with shift. The one with へ on it gives me へ when shifted, and pressing F11 afterwards does nothing; subsequent F10 results in +. – Adarain May 1 '18 at 9:04
  • Literal seconds after writing this however, I noticed that if I input shift+ろ and then hit f10, I do get a tilde - however it is the latin tilde ~, not the japanese ~ that I’m after. – Adarain May 1 '18 at 9:07
  • It appears in general that I can access all the symbols that are displayed in the right columns on this graphic (with the one exception that shift+ほ gives ー, which is not indicated there). i.stack.imgur.com/wPzcp.jpg – Adarain May 1 '18 at 9:14
  • Is conversion to kanji working for you? If you produce the Latin tilde, your IME should give you the Japanese tilde in the options. Otherwise, you can always try to modify your keyboard layout to produce ~ instead of ~. – Earthliŋ May 1 '18 at 10:02
  • I tried that but it doesn't show up in the suggestions. I'd be happy to modify the layout, but I don't know how to go about it. I know how to edit normal layouts but am afraid that the IME would cause troubles. Can I simply load it into the keyboard layout editor, add the tilde and install it or are there extra steps needed? After all it's not quite a normal layout either, with the reverse dead keys and all. – Adarain May 1 '18 at 10:17
  • I haven't used Windows in about 10 years, so I don't know any specifics, but since the IME seems to be working fine, any IME should allow you to add conversion suggestions (in their dictionary). You might have more luck asking on superuser.com for Windows-specific questions. – Earthliŋ May 1 '18 at 11:18
  • 2
    「から」ってひらがなで打って変換したら候補に出ませんかね・・・ – Chocolate May 1 '18 at 13:50
  • 2
    I can also type the wave dash on my phone by typing なみ. – snailboat May 3 '18 at 11:31
  • 2
    for me 〜 is shown as conversion option after typing ー – Igor Skochinsky Jun 1 '18 at 21:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .