1

I am learning Japanese mostly through Duolingo and in a lesson on clothing, I learned the word 履き{はき} for 'to wear' (something below the waist). An example sentence would be:

彼{かれ}は靴{くつ}を履き{はき}ます。

(Hopefully I made no mistakes in that example.)

Usually when I want to write a sentence, all I have to do is write it out in romanji and Windows IME will propose kanji or kana characters where necessary. Sometimes a particular kanji doesn't show up in the context of a full sentence, sometimes kana characters that I don't want converted show up as kanji, but for the most part I can make it work. With this word, however, I never get the suggestion 履き{はき}ます, instead, I start typing 'haki', get a suggestion like 履き心地 and simply delete the unnecessary characters. As soon as I go to 'hakimasu', all the options I get are は来ます、杷木松末 and romanji. It doesn't matter if I write 'hakimasu' as a standalone word or as part of a sentence.

Does anyone know a way to 'add' this word to the vocabulary of Windows IME so that it does show up? Similarly, can you make it so certain kana --> kanji conversions don't happen?

Thanks in advance

| |
  • Yeah, the first predictives when you input はきます using MS IME look really dumb for some reason. But in my case, press space key twice and you get what you might want. – broccoli facemask - cloth Mar 3 at 12:47
  • I get 履きます as a second result. Is the whole word selected? After pressing space once, you can change the length of the selection by using shift + left or right. – Gumamori Mar 3 at 14:50
  • 1
    Getting "は来ます" means your IME made a mistake guessing the word boundary, and in such cases hitting the space bar many times will not do. You can manually modify the word boundary by hitting and (optionally with shift depending on your keyboard settings). See this for an example. Of course there is also a way to add a rare word to the dictionary, but 履きます is a basic word. – naruto Mar 3 at 16:15
  • 1
    @naruto, I noticed a major shift in my Windows 10 IME's predictive abilities about a month or two ago after a mandatory Windows Update. I think Microsoft messed with the code, and screwed things up a bit. I've had to become much more careful about 変換ミス since I noticed the IME making stupid prediction failures. I wonder if the poster's issue is related. – Eiríkr Útlendi Mar 3 at 17:01
0

While the Japanese input methods often do a good work in guessing the different parts of speech, it doesn't always work well. Particularly as the string of kana grows longer...

I find it much easier to force a conversion (space or enter depending on your IME) after each particle. So, in your example: kareha(conversion) kutuwo(conversion) hakimasu(conversion).

You may still need to cycle around the possibilities to pick the right one, but it will be easier that having to re-position correctly the word boundaries if the IME go them wrong.

| |
1

Perhaps you got something like this:

enter image description here

There is a thick line below and another line below 来ます. These lines show how your IME extracted 文節 from the input phrase. The bold line marks the active 文節. In this case, the IME assumed is a particle (that marks whatever comes before this), and きます is the verb you input. When this happens, you need to fix the 文節 boundary manually. Here are the default key bindings:

  • MS-IME: Press / to move the active 文節 and press Shift + ←/Shift + → to change the length of the active 文節.
  • ATOK: Press Shift + ←/Shift + → to move the active 文節 and press / to change the length of the active 文節.

So in this case, if you are using MS-IME, pressing Shift + → three times should fix the problem. This is the most likely solution, but please tell me if this does not work.

Note that modern IMEs make use of the context if you input a longer phrase or sentence at once. If you had typed かれはくつをはきます, your IME would not have been confused.

| |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .