3

Romaji input works just fine, but I've been trying to switch to kana input recently. When I turn the "use kana input" switch on in Metro settings on Windows 10, and then try typing, it gives me this:

enter image description here

As you can see, the characters are still latin. If it were working properly, and I typed the same thing, i'd expect to see ちとしはきくまのり instead. I've tried switching my hardware keyboard to JIS layout, but the problem remains. This problem occurs on both Microsoft's IME and Google Japanese IME. If anyone knows how to solve this help would be much appreciated.

| |
1

Sounds like you have some configuration to do -- your IME settings aren't quite right.

The below is for the MS IME on up-to-date Windows 10.

  • The MS IME has a few different modes. I assume that Google's does too. One of these modes is Full-width Alphanumeric, which is what your sample output looks like. In this mode, the IME faithfully accepts keyboard input and produces the full-width (i.e. double-byte) characters for those glyphs. If I change to Full-width Alphanumeric mode and type your same sample string, I get asdfghjkl.
    → For kana input, you'll need to change the modes Input method, most likely to the Hiragana mode to Kana Input. For the MS IME, right-click the IME icon in the lower-right task bar and select Hiragana Input Method and then Kana Input from the pop-up menu.
    IME settings for direct kana input
    After clicking Kana Input, the IME should automatically switch into Japanese mode. If for some reason it hasn't, make sure to switch it manually. On Windows, the default keyboard shortcuts are either Shift + CapsLock, or Alt + ` (the backtick under the tilde, on the upper left of the keyboard). The IME icon should change from the capital A in the screenshot above to a hiragana as shown below.
    IME in Japanese mode
  • Also, for romaji input, the IME -- either Microsoft's or Google's -- only converts valid letter combinations into kana. Only the initial "a" in your sample string would have been converted (to あ), even in Hiragana mode. あsdfghjkl is what I get when I type that same string in Romaji Input and Hiragana mode using the MS IME.
  • IME behavior is separate from keyboard layout. I've got the US keyboard layout active, but if I switch the IME mode to Input method → Kana Input, the same sample string from your question produces ちとしはきくまのり instead.

TL;DR: change to Input method → Kana Input, and then change the conversion mode from Full-width Alphanumeric to Hiragana make sure it's in Japanese mode, and not Full-width Alphanumeric.


Please comment with any further questions about the above.

| |
  • No, the problem isn't with the input mode I'm in. When I typed that string, I was already in hiragana mode. For some reason it still isn't giving me japanese characters even when I type in hiragana mode. – konomu Mar 3 at 1:59
  • This part seems to be the error: "change to Input method → Romaji input" I think you meant to say "change to input method -> Kana input". That produces the correct result. The thing you have suggested doing gives the usual romaji to kana type of input, but OP wants to type using the kana keyboard. – Ben Mar 3 at 2:09
  • I have been typing with kana input and hiragana input, but the text still outputs latin characters. – konomu Mar 3 at 2:23
  • @konomu, the UI instructions above are for the MS IME. Could you clarify which IME you’re using — Google’s, or Microsoft’s? – Eiríkr Útlendi Mar 3 at 7:00
  • 1
    @Ben, thank you. That's what I get for posting when tired. Updated to address the appropriate question. – Eiríkr Útlendi Mar 3 at 16:58
  • @EiríkrÚtlendi I'm using Microsoft's IME. When I typed that string of letters in my original post, I was already in kana and hiragana mode. I even have the あ icon in my taskbar. But it still ouutputs latin characters for some reason. I think it may be a bug with the OS, unfortunately. – konomu Mar 3 at 23:35
  • @konomu: It does appear to be possible to have Input Method → Kana Input and have the IME mode set to Full-width Alphanumeric -- but when doing so, the IME icon changes to a full-width (i.e. double-byte) fat letter . I can't reproduce the exact conditions you describe, and I too am starting to think you've run into a bug. Questions: 1) Does this happen in every app, or only some? 2) In the Region & language settings, what do you have for a) Country or region, and for b) Windows display language? Past there, I'm out of ideas. – Eiríkr Útlendi Mar 3 at 23:47
  • 1
    @EiríkrÚtlendi I tried setting my region and display language to Japanese, but it still didn't work. I'm going to try updating to the newest windows version and see if that helps. – konomu Mar 4 at 0:58
  • 1
    @konomu, good luck, and let us know how it goes. – Eiríkr Útlendi Mar 4 at 3:19
1

I believe I have found the root of the problem. The kana input started to work after I updated. The problem comes from the specified .dll file associated with the KBDJPN layout in the registry editor. Previously, I had assigned a custom Colemak keyboard to this position, and while this works fine with romaji input, it seems that the Colemak.dll file cannot be used with kana input. If you have this problem on previous versions of windows, you should go into the registry edit and under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts\00000411, double click "Layout File" and change the data to KBDJPN.DLL.

Unfortunately, this solution gets rid of our colemak keyboard for inputting romaji. I suppose you could just use windows+space to cycle through languages, but there are a few problems with this.

  1. Switching languages requires you to press the alt+tilde shortcut every single time you want to start inputting hiragana.
  2. If you have a keyboard configured with qmk that is physically not identical to the japanese JIS standard, you will have trouble using both languages. I have configured my custom keyboard so that punctuation and numbers are in a different place. As such, when I try using kana input, some kana keys that take the place of numbers normally are in the wrong place.

There is one way that I believe I can fix this. This webpage explains how you can use Visual Studio and Windows Driver Kit to edit a registry file called kbd106.dll to make japanese input compatible with ANSI. Normal keyboard layout editors, such as Microsoft Keyboard Layout Creator 1.4 do not allow you to edit VK_KANA, which is the virtual key code that controls kana input. The other program that I found, kbdedit, that allows you to do this, is locked behind a paywall. I tried using the method indicated in the webpage I linked above, but couldn't get it to work. Ultimately, I just gave up and bought kbdedit, and that seemed to do the trick.

| |
  • Good sleuthing! I hope you eventually find a more optimal solution. – Eiríkr Útlendi Mar 4 at 23:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .