39

The quick-submit of comments through the Enter key is a real nuisance on this site. When inputting Japanese through an IME you are required to use Enter, which also submits the comment. Having to remember to hold Shift every time is annoying and may even interfere with some IME's input (possibly, I don't know).

Also see Pressing Enter in comment box unexpectedly submits form.

32
  • 3
    This needs to be changed. Even if there was some other key stroke combination (like Shift+Enter) that might work, typing is so automatic that in all likelihood I'm going to continually forget to do that. Given that there is an "Add Comment" button right there which is immediately accessible by hitting "tab", the enter-to-submit system is an unneccessary and confusing "feature" for those of us using IME. (I use ibus/Anthy on Ubuntu, by the way.)
    – Questioner
    Commented Jun 1, 2011 at 4:03
  • In Windows 7, while enter is used for the IME, I am able to use it successfully without it submitting the comment without doing anything special. Commented Jun 1, 2011 at 4:55
  • @rebecca - how are you able to get it to not post the comment? as I am also on windows 7 and have had this problem so many times today i've resorted to writing in romaji. Commented Jun 1, 2011 at 5:09
  • 1
    @MarkHosang, can you give me some exact key stroke steps to attempt to repro? I just used the IME like I normally do and didn't encounter a problem. Commented Jun 1, 2011 at 5:11
  • I just tried some tests, and it appears to happen in comments after you have surpassed the minimum charter count. these were my key strokes split by space {k a n j i <space> <enter>} and {t e s u t o <enter>} both resulted in an immediate post. Commented Jun 1, 2011 at 5:22
  • Oh yes please. This has been annoying the hell out of me.
    – Ali
    Commented Jun 1, 2011 at 6:56
  • I was thinking of posting this yesterday. This definitely needs to be fixed. Commented Jun 1, 2011 at 9:28
  • Ctrl-J Ctrl-J Ctrl-J... I've been thinking of whipping out my Japanese keyboard just so I can press only one button to submit instead of this annoying combination... Commented Jun 1, 2011 at 12:53
  • 1
    @MarkHosang: in this comment I have 感じ and てすと and with no auto-posts from using enter in the IME, I'm still typing, and now I'll hit enter to submit the post... Commented Jun 1, 2011 at 15:55
  • 漢字 テスト テスト テスト テスト
    – Ken Li
    Commented Jun 1, 2011 at 18:02
  • yep it auto submitted for me
    – Ken Li
    Commented Jun 1, 2011 at 18:02
  • 4
    Can repro in Firefox. Chrome handles things properly. /blame Firefox. Commented Jun 1, 2011 at 18:34
  • 1
    Repro in Firefox 4.0.1 and IE 9.0.8112.16421, not repro in Chrome 11.0.696.71, all on Windows 7 English version with Microsoft Office IME 2010 (for Japanese). Commented Jun 4, 2011 at 0:17
  • 1
    Kind of surprised by those on OS X who are saying this isn't a problem. I've been struck by it several times already, using OS X 10.6 with a WebKit browser (OmniWeb), using the Return key (On the Mac, "Enter" is only used for the lower-rightmost key on the ten-key keypad). SE needs to not do this. (And if you could somehow remove this annoyance from Facebook as well, it would be appreciated.) Commented Jun 12, 2011 at 5:48
  • 2
    @Garrett Actually, we are saying it's a problem on OS X too. @deceze Maybe this should be retagged as bug since it's interfering with using the site?
    – Troyen
    Commented Jun 13, 2011 at 6:56

3 Answers 3

7

It appears this request has been honored. Enter no longer seems to submit comments on JLU.

5
  • Which browser and version are you using? With Firefox 4.0.1 on Windows, it still submits comments. テスト Commented Jun 22, 2011 at 13:26
  • 1
    @Tsuyoshi Any browser I tried, but only on the main site, not meta.
    – deceze
    Commented Jun 22, 2011 at 13:31
  • 1
    Oh, I see. Indeed, Enter stopped submitting comments on the main site. Yay! Commented Jun 22, 2011 at 13:33
  • 2
    Just for completeness sake, this was changed with proper IME handling in June 2016: Improved IME Handling is now active Commented Jun 30, 2016 at 15:45
  • Nearly 12 years later, I am having the same exact problem with a Linux IME (fcitx/mozc). Worse yet, it seems that shift-enter doesn't do anything, so I can't even work around the problem. Commented Apr 9, 2023 at 0:23
3

I use this user script. This at least prevents the Enter key from erroneously sending a comment when you are writing a new comment. This is just a workaround and not a proper fix, but an incomplete workaround is better than no workaround.

Edit: The old version did not prevent the Enter key from sending a comment while editing a comment, but the new version (June 7, 2011) does.

1
  • 1
    Zannennagara this doesn't work on Safari (at least without more hacks). Also, virtually every user of this site will have this problem, so I think it should be addressed by the Stack team.
    – deceze
    Commented Jun 1, 2011 at 2:27
-3

Most IMEs allow you to rebind the commit keystroke to some other key with less side effects; you might want to consider doing so?

6
  • 11
    I do not agree that I should have to reconfigure my IME that I use everywhere on the system only because Stackexchange decides to go against the standard and act on Enter presses in textareas.
    – deceze
    Commented Jun 1, 2011 at 2:03
  • 3
    As this is the default keystroke of Microsoft and many other IME's so we really can't expect everyone to change their IME keystrokes just for the sake of this SE site.
    – Ken Li
    Commented Jun 1, 2011 at 2:04
  • 5
    I agree with the other commenters that it is not reasonable to ask users to change for the site. The site should be in line with the most common practise of its user base.
    – Questioner
    Commented Jun 1, 2011 at 4:04
  • 2
    +1 Even if this is not a long-term solution and SE should fix it, bdonlan's workaround is helpful, so I don't understand why people down-voted this answer. Commented Jun 1, 2011 at 4:12
  • @Nicolas I did not downvote so idk but I think the people who downvoted probably interpreted this answer as that we should be expecting everybody should fix their own IME's settings instead of fixing the behavior itself, which is unrealistic in the long-term just as you pointed out.
    – Ken Li
    Commented Jun 1, 2011 at 5:08
  • 1
    You guys should keep in mind that the meaning of downvotes on meta is different from the main site: they do not affect anybody's reputation and are a good way to express your support for a solution or another, when addressing a technical problem. Bottom line is: don't take it personally, or as a measure of the value attached to your answer :)
    – Dave
    Commented Jun 18, 2011 at 5:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .